Results

OpenDNS Inc.

09/06/2019 | News release | Archived content

Deprecating Support for TLS 1.0 / 1.1 – Improving Encryption Strength and your Security Posture

TLS Background

Transport Layer Security or TLS provides privacy and data integrity for applications communicating over the Internet. It can be used in many Internet services today such as VPN, Email Exchange, and most commonly,Web Services (HTTPS). There have been 2 released versions of Secure Sockets Layer (SSL) and 4 versions of TLS spanning the last 25 years of security advancements. Each successive release addresses security vulnerabilities or weaknesses in a prior release:

  • SSLv2 documented in RFC 6176, released in 1995
  • SSLv3 documented in RFC 6101, released in 1996
  • TLS1.0 documented in RFC 2246, released in 1999
  • TLS1.1 documented in RFC 4346, released in 2006
  • TLS1.2 documented in RFC 5246, released in 2008
  • TLS1.3 documented in RFC 8446, released in 2018

Current TLS Support

Our mission within Cisco Umbrella has always been to provide powerful security solutions that are easy to deploy and simple to manage. To maintain the simplicity for our customers and provide for the most backwards compatibility for those running legacy or unpatched operating systems, Cisco Umbrella has previously chosen to continue supportingall TLS Protocols 1.0 or later, deprecating only specific weak / insecure ciphers.

What's Changing?

Cisco Umbrella will deprecate support for all TLS / SSL versions prior to version 1.2 on March 31st, 2020. After this date customers will be unable to connect without leveraging a TLS1.2 compatible client.

Why change now?

There are a fewcompelling events that caused us to re-evaluate our risk evaluation of TLS1.0 / 1.1.

1 - Apple, Google, Microsoft, and Mozilla announced in October of 2018 that they will deprecate support for TLS1.1 andprior within their browsers,forcing all TLS communications to be TLS1.2 or higher on March 31st, 2020.

2 - As of June 2018, the Payment Card Industry Security Standards Council (PCI-SSC) officially began enforcement of a new policy requiring any sites certified under PCI-DSS to deprecate TLS1.0 and any SSLv2/v3 configurations. While they will allow TLS1.1, there is a strong recommendation to implement only TLS1.2 and later protocols.

3 - As of 2014, the National Institute of Standards and Technology (NIST) formalized policy 800-52 which requires US Government Agencies to adopt TLS1.2 and deprecate use of TLS1.1 and before.

Upon re-evaluation of the associated risks and certification landscape, Cisco determined that now is the time to complete deprecations for anything prior to TLS1.2.

This post is categorized in: